Jump to content

SCS v21 Crashing Leaving Candlekeep


Recommended Posts

After a lot of trial and error, I have narrowed down a crashing issue to SCS v21. I have installed the game using the GoG versions and BGT. I tested after each mod install. The crash happens after the installation of SCS. It occurs when Gorion attempts to take the NPC out of the city (right after the speech about meeting Khalid and Jaheira).


I have attached two log files. If you need any other info let me know.



Link to comment

Do you get the bug if only SCS is installed, or do you require other mods to be present as well? If the latter, it's some kind of compatibility issue.


EDIT: I can reproduce this on an SCS-only install with exactly your install order. Watch this space.

Link to comment

Curiouser and curiouser. I can reproduce the crash with just BGT installed (i.e., without any part of SCS). It's sporadic, though, and doesn't usually seem to happen if you linger to shop and equip before leaving Candlekeep.


There's a thread on the BGT forums here that discusses the issue.

Link to comment

I tested again last night. I even went ahead and installed NPC Mods before SCS (Amber, Fade, Angelo, Keto, Kelsey, and Xan) along with LVL 1 NPCs. I tested the game, no issues. So, I installed SCS and skipped "Skip Candlekeep" as I read a post that somebody had an issue with that. Crashed again, same spot. RIght after the Friendly Amn speech and before the loading screen.


I'll check over at BGT and see if there are any ideas. Thanks.

Link to comment

For what it's worth, here's my testing framework: initially I was mostly using "Skip candlekeep", and I imported a fighter, jumped him straight to Gorion, and went straight out. It crashed maybe two thirds of the time. I then tried creating a character, ignoring the "skip Candlekeep" fighter, shopping, and sauntering over to Gorion. Again it crashed reasonably frequently - perhaps a little less frequently, but it wasn't statistically significant.


I then started rolling back SCS about ten components at a time. In each case I still got crashes. Even with the whole thing uninstalled they still occurred. It's possible that they were rarer, but again it's difficult to be sure.


For technical reasons I wasn't able to remove ToBEx, so it's also possible that the crash is connected to that, but I have absolutely no evidence that that's the case. You could try adding the line "Disable_ToBEx 1" to the "scs.ini" file and then reinstalling the mod. (Obviously that won't achieve anything if you also have ToBEx installed in its own right, but it disables the installation of the version that ships with SCS.)


I'd also be interested if you get crashes every time, or just often. I was able to get up to four consecutive runs without a crash. (Intermittent bugs are so much more annoying than reliably-reproduced ones!)


I can only assume that there must be something odd going on here, as SCSv21 has been out for a while and this is the first I've heard of the bug - and, as I say, because I can reproduce it with the whole damn mod uninstalled!

Link to comment

I have use dit in the past no issues. I am installing using WINE on OSX. This my first time using BGT. I just finished a run through using BGtutu and BG2 installed from original discs using Crossover (a packaged WINE). Anyhow, I saw that all the Mac users now were going with GoG editions, using WINE, and BGT being updated more recently. I had SCS working fine on the last install.


I have tried several times without SCS and no crashes, but crashes every time for me (6 tries) with SCS. When I get home I'll disable TOBex and see if that does the trick.

Link to comment

Okay, I'm completely perplexed. The version of BGT I was using earlier is a bit messed up by being used as a mod building ground. So I installed a completely clean (GOG) version of BG2, ran the BGT converter, and then installed the Initialise and Skip-Candlekeep components of SCS. I'm totally unable to reproduce the bug now: I get the cutscene eight tries in a row.



It's obviously not something specific to your system because I was able to reproduce it on my previous build (and on 64-bit Windows 7, not OSX). Equally, it's something idiosyncratic. My best advice is for you to start again - clean BG2, clean BGT install - install SCS, and see if you get the crash. If not, try rebuilding your mod package...

Link to comment

I am going to try something different today. I have been using the Windows versions of the mods as it it is the Windows version of the game. The other mods work fine, but that may be an issue with SCS. So, I am going to install GoG Windows version using WINE and then SCS OSX version. We shall see.

Link to comment

That is how I have done in the past. OSX Mods on Windows BG2 using Crossover. There used to be Macfinity site for all things Infinity Mac related. The guy that ran it. Lord Jeremy, was the one who told me about having to use OSX Mods on the Crossover Windows install of BG2 and it worked the last few times I installed the game. I am having trouble now as I am getting permissions errors on the OSX mods. I remember that happening before and I had to chmod in terminal, but forgot what exactly and the website is gone.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...