Jump to content

iPad and GemRB - Help please!


Recommended Posts

Hello everyone!


I've tried following the instructions in the wiki to no avail using the latest recommended build. I'm a complete newbie (except I did try this once a long time ago) at this GemRB thing and am finding previous posts of little help, please help me.


What I know so far:


I have a jailbroken iPad 2 running iOS 5.1

I have GemRB-ios-v0.7.0-292-g654f183.ipa installed sucessfully

I would LIKE to run BGTutu - is this even required? Does GemRB automatically import the BG2 features in BG1?


Thanks everyone!

Link to comment

Sorry for the late reply: I was expecting an email notification. I guess not.


So, I would set up BGTutu as BG2, got it. How would I do it? I tried copying it as bg2.zip to GemRB using iTunes and launching GemRB to create an auto configure.... But GemRB just opens and closes.


What I zipped was the entire BGTutu dir. Was this right?


If someone could send me a .txt with their directory structure of GemRB I could pull a whole bunch of information out of that. Also, the installation instructions mention both copying the .cfg file and the autocreation of one. Which is it?


Thanks guy!

Link to comment

Here's the confusion on my part according to http://www.gemrb.org/wiki/doku.php?id=install:ios


From the Installation section, filed under #6:

"load the config file via iTunes file sharing to GemRB. GemRB auto generates config files now."


Andvfrom under the "Game Installation" section:

"This config file will contain automatically generated paths to the data."


And the .ZIP idea cam from:

"iTunes can also be used to upload games. simply create a zip archive of the game directory and rename the file extension to the GameType for the game (ie BG1, BG2, IWD, PST…). When you run GemRB after uploading a game you can choose to install the game which will unzip the archive to “Library/GameType” and copy the default configuration file and name it “foldername.gametype.cfg”."


I'm just further confused now :S

Link to comment

Hmmm. My excitement has abruptly ended. GemRB is not responding to my touch interactions, leaving me at the opening windows of BGTutu and BG2.


Can someone else try the latest builds and report if they have the same issue? Syntax, is there some information I could provide you that might be useful?

Link to comment

I just updated the libSDL on the buildslave. the change log indicates some coordinate fixes for retina displays so you can try some later builds and let me know.


I do know the new library at least fixes the annoying bug of the screen being flipped around when actually launching a game from the wrapper tho.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...