Jump to content

5E Spellcasting Rules Conversion


Recommended Posts

5 hours ago, Lily_EvilDM said:

while it does give me all the memorized spells spontanously it also gives me a single cast of every spell I memorized

Okay:

  • What level are you?
  • What is your WIS score?
  • Are you wearing any bonus spell slot items?
  • After you rest, and after you let the game clock run for a few seconds, if you click 'P' to go to the priest spellbook,

...

EDIT - whoops, okay I see now, I already found that bug and already fixed it, I just haven't yet released the fixed version yet.

Try using this hotfix mod and it should be fixed.

Link to comment

Just tried your hotfix mod and it seems to have solved that problem completely! However for Mage/priests there seems to be a different issue. Other than the spells changing locations, Which I believe is a known issue, all the spells seem to be cast-able way to many times. as a level 6/6 Abjurist of Mystra eith 19 Intelligence and 18 wisdom and without gear could cast 3rd level spells 6 times 2nd level spells 9 times and first levels spells either 9 times or 18 times. Also casting a priest spell costs a use of mage spells at the same level except for a few spells  (magic missile Chromatic orb and Acid arrow, possibly more as I only had time to test out a few combinations)

Something further I just noticed. My q and my a key trigger the casting of my highest level spell. Which since q is my quicksave key is not ideal though for now I can get around it by binding that to a different key. Changing keybinds does not seem to help. Nor does changing scripts or turning scripts on or off. Not sure if this is 5E or another mod doing this though. Planning to create several different installs in the coming few days with different combinations of mods to see if I can find out more :)

Edited by Lily_EvilDM
Link to comment
20 hours ago, Lily_EvilDM said:

all the spells seem to be cast-able way to many times. as a level 6/6 Abjurist of Mystra eith 19 Intelligence and 18 wisdom and without gear could cast 3rd level spells 6 times 2nd level spells 9 times and first levels spells either 9 times or 18 times. Also casting a priest spell costs a use of mage spells at the same level except for a few spells

This stuff is fixed in version 1.0. The "too many casts" thing was because the ability score bonuses were being doubled - +4 spells instead of +2. I don't have a hotfix for this but if you don't have much installed after it, you can uninstall the Scales of Balance ability score bonus spells component, and then update SoB to version 5.32.5, then reinstall it.

Link to comment

ERROR locating resource for 'COPY'
Resource [SPWI975.spl] not found in KEY file:
        [./chitin.key]
Stopping installation because of error.
ERROR: [d5zclons.2da] -> [override/d5zclons.2da] Patching Failed (COPY) (Failure("resource [SPWI975.spl] not found for 'COPY'"))
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [Change All Casters to 5E System], rolling back to previous state
Will uninstall 2171 files for [5E_SPELLCASTING/5E_SPELLCASTING.TP2] component 100.
Uninstalled    2171 files for [5E_SPELLCASTING/5E_SPELLCASTING.TP2] component 100.
ERROR: Failure("resource [SPWI975.spl] not found for 'COPY'")
Please make a backup of the file: SETUP-5E_SPELLCASTING.DEBUG and look for support at: SubtleD
Using Language [English]

Link to comment

The Darkest Day/TDDz would.

I say would, because it only installs SCRLX41.ITM without the spell associated with it (the spell file does exist in TDD, it just doesn't get copied to override). I know the Roxanne version did it and she should have fixed it by now after @Endarire passed my complaints at one point (and forced me to register to that cesspool of darkness because he was unable to explain it properly), but I never tested/checked if the InfinityMods version also includes the problem and/or provides a fix.

Edited by Graion Dilach
Link to comment
19 minutes ago, Graion Dilach said:

The Darkest Day/TDDz would.

I say would, because it only installs SCRLX41.ITM without the spell associated with it (the spell file does exist in TDD, it just doesn't get copied to override). I know the Roxanne version did it and she should have fixed it by now after @Endarire passed my complaints at one point (and forced me to register to that cesspool of darkness because he was unable to explain it properly), but I never tested/checked if the InfinityMods version also includes the problem and/or provides a fix.

Huh. Okay. So I copied SPWI975 into my override out of the old TDD folder and wound up with this instead.

[weidu_external/d5_semi_cast/d5zlotr.baf] PARSE ERROR at line 4 column 1-4
Near Text: THEN
        [NextTriggerObject] not found in TRIGGER.IDS for TriggerOverride; missing ToBEx?

[weidu_external/d5_semi_cast/d5zlotr.baf]  ERROR at line 4 column 1-4
Near Text: THEN
        Parsing.Parse_error
ERROR: parsing [weidu_external/d5_semi_cast/d5zlotr.baf]: Parsing.Parse_error
ERROR: error compiling [weidu_external/d5_semi_cast/d5zlotr.baf]: Parsing.Parse_error
ERROR: compiling [weidu_external/d5_semi_cast/d5zlotr.baf]!
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [Change All Casters to 5E System], rolling back to previous state
Will uninstall 2236 files for [5E_SPELLCASTING/5E_SPELLCASTING.TP2] component 100.
Uninstalled    2236 files for [5E_SPELLCASTING/5E_SPELLCASTING.TP2] component 100.
ERROR: Parsing.Parse_error
Please make a backup of the file: SETUP-5E_SPELLCASTING.DEBUG and look for support at: SubtleD
Using Language [English]

 

At this point I'm thinking TDDz should probably run after 5E Spellcasting, though. As a side note, weidu_external/d5_semi_cast/ is an empty folder.

Edited by RelentlessImp
Link to comment

I think some mod might be overwriting your TRIGGER.IDS file...? Because that's weird.

EDIT -

I've updated the mod to version 1.0.2 with some extra FILE_EXISTS checks so it doesn't get tripped up on the bad TDDz scroll. That won't fix your script-compiling issue, but I don't know what will because it installs just fine for me on every game I can test on.

Edited by subtledoctor
Link to comment

Huh. Well, once the new FILE_EXISTS stuff went in I wound up at the same error once the SPWI975 was out of my override folder. It's definitely an install order issue at this point, think, then. Going to try putting all the kit stuff near the top of the load order this time, see if that solves issues down the line with more robust quest mods like TDD.

Edited by RelentlessImp
Link to comment

I mean, I think it's a bit more than install-order issues... if some mod is messing with TRIGGER.IDS and ruining capabilities introduced in the EE engine, it's probably worth finding out which.

(I'm also surprised that compiling a script depends on something being in an .IDS file... I thought those were just illustrative, not functional. You haven't said what version of the game you are trying to install this on. If it's not 2.5 or 2.6, that will likely cause problems.)

Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...