Jump to content


Guest Guest

Recommended Posts

Hi, I'm somewhat puzzled about a problem that occurred me with P&P Celestials mod, and as I'm pretty sure there is a logical explanation, I ask here.


I decided to test the changes mentioned on the mod first hand, so I summoned a couple of Devas, Astral Devas and Planetars... you get the idea. The first two seemed okay, thing is that to my surprise, instead a Planetar, my mage spawned "Eclipse Avenger +4" (eeek?); it even says the item description on the dialog window when casting spells, taking damage, etc... hilarious.


I said to myself that somehow I must have corrupted the mod, and proceeded to check what was the problem with NI. The root seemed to be in the same mod files (Celestials folder and its files in my BGII directory): the CRE and ITM files were somehow corrupted and contained strange names, like "Eilistraee's Blessing", "Eclipse Avenger +4", etc.. . As I did not know what the heck was Eclipse Avenger and such, I used CTRL-Q to add the summons to the party to find clues, and in both Devas and Planetars, their weapons had the very first Soulafein dialogue when he joins the party!


Well, I figured I did something wrong installing it, but still I checked an untouched mod backup with NI, and it still had the same files!?


Now I thought that maybe I did something wrong with the backup aswell, so I downloaded it again, today, 5 mins ago... and now checking the files with NI, they are the same corrupted files.


What the heck is happening here?

What am I doing wrong?

Am I misusing NI or something? I have checked various files with it before, and I never had this problem.



Link to comment

The ingame problem sounds like an install issue, though I won't rule out a bug with the mod. :D


As far as the string references being screwy in the mod folder--strings such as descriptions, names, and what not are not actually stored in items and creatures. What the files actually contain are a number that corresponds to a reference in your dialog.tlk. When you look at files in the backup, they likely have a random number in these fields. Because they're not installed, these strings will point to something random in the dialog.tlk.


At installation, WeiDU will add appropriate strings to the dialog.tlk file and alter items, spells, etc. to point to the new strings. You should be able to see a similar "problem" with items and creatures from any mod. You can also see the same problem if you open your BG2 game with NI, then looks at an item from IWD--NI will try to look up the string references from the BG2 dialog.tlk and you'll end up with random strings in the name and description.


Another common problem is installing and uninstalling mods and then continuing from an old savegame. NPCs, for example, are stored in the savegame, so their string references are no longer correct after (un)installing mods. This is why many NPCs include string fixers. :D

Link to comment

Okay that makes perfect sense now. I did not rule out a bug with the mod either, but one that big? and going unnoticed so far? That's not realistically possible in my book heh, hence my post above asking for what "I" was doing wrong.


Recently I performed a reinstall of the complete modded game, eliminating a few mods and components not for my taste... but used the same old savegames to continue where I left.


I have read that some .tlk strings are somewhat random, and issues like this can happen in a reinstalled game using old saves. I had a similar problem with Towncriers dialogues being replaced with items', but I fixed it (sort of) replacing the savegame damaged areas with the game's own.


In fact this is the first thing I thought to be possible when the mod turned to be corrupted, thus I tried to use the mod backup or the recently downloaded one to replace the corrupted files... but I lack of the knowledge to do this, if it's possible even.


Funny that I forgot to mention my reinstall issue, even when I first thought it could be the very cause... forgive me please.


*Sigh* I've trying to finish a full modded game for some time now, the first time I had to reinstall to remove some mods that caused trouble, the second to change the game's language version to english, and have everything under the same sun... now it has been my fault for using old savegames. CRAP


I'm afraid this problem can get worse if I advance more in the game, but I'm reluctant to restart again. Is there a way to fix this self-bug that I could do, or am I doomed to restart again?


Btw, I take the game is corrupted for good then? I tried starting a new game to check if this was a savegame isolated problem, but the Eclipse Avenger +4 was still there nonetheless.


Thanks for the fast reply btw.

Link to comment

What may work is trying to reinstall the PnP Celestials mod, so the string locations are updated. However, this very well may not work, and even if it does it may cause more problems. Sorry I can't be of more help, but I haven't really considered BGII for the past 4+ months. Maybe one of the more skilled individuals around here could be more helpful.

Link to comment

Reinstalling the mod did not work, but with a bit of patience I modified the "mistaken" string number of each file to match with the correct descriptions. Their spells, innates, etc... seemed correct so no problem there. Also I've checked the eclipse party and they are fine aswell.


When I complete the game I will make sure to reinstall everything correctly and never use a saved game again.


Thanks for all the help provided here tho.

Link to comment

I know exactly what you've gone through. A few times when I was trying out various mods I ended up playing through the first part of the game so many times I got incredibly sick of it. Its too bad you can't just patch onto a savegame, but with my Weidu skills, that isn't really an option.

Link to comment

Haha, I just recently had this happen to me. But my Planetar that was summoned was called "Enough talk then. Let's see how tough you really are!" :rolleyes:


it was funny every time it cast a spell or took damage because it always said "Enough talk then. Let's see how tough you really are! - Casts Aid: Enough talk then. Let's see how tough you really are!" Pretty funny if you ask me.


After uninstalling and reinstalling a couple of mods it worked out fine, though.

Link to comment

These errors are simply because Caedwyr (and most others) assume some strings correspond to entries that are correct in the standard SoA-ToB-Fixpak-WeiDUmodXYZ- installation, but have been modified by several mods (I've compared my BP Dialog.tlk and the standard SoA Dialog.tlk, and I was right!).


Also, a few of the WeiDU commands didn't work correctly as they were supposed to, for some reason.


Fortunately, I have already fixed these errors yesterday, when I revamped some of the spells and packaging. :rolleyes:



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...