Jump to content

Two questions on this mod


Recommended Posts

At least knowingly, I have not installed a Widescreen mod anywhere; what I have is:

 

IWD - the Fixpack

BG2 - the Tweakpack, a mod that changes the transparency of the Cloak of Mirroring, and Unfinished Business

IWD in BG2 - the mod itself, the accompanying fix/tweakpack and Icewind Dale NPC

 

No idea about the possible impact of any of them, but that should be the full list. Unless the ToB patch 26498 might have anything to do with it, I am really not sure where this could come from.

 

Shall I still follow the first suggestion and edit the .ini file/run again?

Link to post

If you are missing 2.5 GB of data due to antivirus quarantine during installation then I'd solve that first (by reinstalling from scratch with antivirus off).

 

Second make sure the HD and CD lines in the baldur.ini file point to the correct location (the folder where that file - and the rest of BG2 - actually is). Do that before installing any mods.

 

Third, if it still crashes, edit the ini and run again.

Link to post

Essentially, I am not sure if this is the reason - that's why I was looking for a log, hoping it might provide some additional clarity - to reiterate, I don't see one, though.

 

That aside, my own "gut feeling" at the moment is to try reinstalling, which is why I was asking about a "proper" way to uninstall the mod - the others that I have have setup.exe files to use, and I don't see one for IWD-in-BG2, the readme is not very specific on uninstalling, and just deleting the directory doesn't seem to be the cleverest of approaches.

Link to post

That aside, my own "gut feeling" at the moment is to try reinstalling, which is why I was asking about a "proper" way to uninstall the mod - the others that I have have setup.exe files to use, and I don't see one for IWD-in-BG2, the readme is not very specific on uninstalling, and just deleting the directory doesn't seem to be the cleverest of approaches.

Uninstall what mod... if you mean the IWDinBG2, then you should know, it doesn't use the Windows Install Shield, so uninstalling it via removing the folder is the only real way to do so... uninstalling the other mods too, by uninstalling the games they are installed in is also the thing to do(and removing the install folder as that contains the modified files). And reinstalling them then back. As the weidu mods are completely unofficial expansions of the games they are part of... that's really the only way to guarantee their uninstall. Yes, the weidu also provides uninstall option in the regular mod... BUT understanding the fact that as the IWDinBG2 should take 5Gb's space and it only taking 2.6GBs... part of exportation of the files failed, and thus the need to remove, being the recommended thing to do... you should just go with it. So you can then reinstall the things.
Link to post

When it comes to very large mods, the likelihood that uninstalling will be perfectly symmetrical (will restore all files to exactly the same original state) is low. Therefore I always recommend starting from scratch even though it might take longer.

 

Since you want to investigate further before taking that step, try the debug log method first. If you still see no log files after setting all debug lines to 1, I will be very surprised.

Link to post

Trying to start the game again with all Debug options in TobEx_ini\TobExCore.ini set to 1, I get:

 

1. The same error message as before.

2. Some new files in the main directory - Baldur.err (0 KB), dialog.tlk, Input (1 KB), TobEx_dlg.log (1 KB, contains only a header).

 

That aside, I don't think I see much that is different. Would any of this help with diagnosing, or shall I just proceed with reinstalling?

 

Edit: Baldur.log, as before, seems to be blank.

 

Second edit: If there is anything specific to look for anywhere in the directories, please let me know.

Edited by DragonRider
Link to post

My recollection (not at my computer now) is that there would be a TobEx.log file also, but if you do not see anything meaningful in any log files, the crash must be happening very early in the start process. I would go ahead with re-installing at this point since we have reason to believe your current install is incomplete. If you still have the same problems after reinstalling, we can do further investigation of the logs (or lack thereof).

Link to post

There is, indeed, such a log file, but all it contains is several copies of the error message I already posted above, evidently one for each time I tried to start the game.

 

Regarding reinstalling, just to be on the safe side again, I use the setup files for IWD NPC and the fix/tweakpack to remove them, and then simply delete the IWD-in-BG2 directory?

Link to post

Don't bother running the setup files to uninstall. Restore your game folders to their original state (delete everything you have now and either restore from backups if you have them or use the official Bioware/Beamdog game installers). Run each game unmodded once, creating a saved game (just to ensure everything works and to set some basic config checked by some mods, such as your game language). Proceed from there with installing mods as normal (ensuring User Account Control and antivirus quarantine features are disabled while the mods are actually being installed).

Link to post

One more question - when the installer was asking for the paths to the games, it said in all caps to give them "without any terminal slashes". Whatever exactly would a "terminal" slash be, as I don't think I've seen this in use elsewhere?

It's that you should use this as an example paths:

C:\Users\username\My Games\Black Isle\Icewind Dale

C:\Users\username\My Games\Black Isle\BGII - SoA

 

While DEFINITELY NOT the:

 

C:/Users/username/My Games/Black Isle/Icewind Dale/

C:/Users/username/My Games/Black Isle/BGII - SoA/

This is because the ran operation would try to associate the terminal slash marks as a command features ... like /c could for example be a shorthand for COPY -operation of the former files. So you can't use the / 's, while you ought to use the \ 's.

Edited by Jarno Mikkola
Link to post

Ok - I have run into some trouble reinstalling Baldur's Gate to obtain the clean installation - first, I uninstalled the mods, indeed, using their setup files; then I uninstalled Throne of Bhaal, using the setup file on the disk; that's when the problems began, because once ToB uninstalled, it displayed a message that now SoA would uninstall, nothing of this sort happened. Upon trying to run the ToB setup file again, a message came up saying it does not detect the SoA registry key; SoA seems to be in its place (files are in the folder), when running its setup file from the disk, it asks if I want to uninstall the application (therefore, detecting it as installed); if I answer yes, a filled up to 100% bar appears for a second, but everything in the folder is still there. Restarting the computer doesn't help, nor does trying to uninstall from Control Panel or using CCleaner. Not quite sure how to proceed at this point.

 

Suggestions, please?

 

Addition: The registry key issue might - but this is my guessing - have to do with the following: at first, I tried to install the game a second time, so as to have one clean installation and keep the modded one; maybe because I had ToB already, but SoA installed without a problem to a different directory; then, when I tried to install ToB, it evidently detected the one already in place, since the installer asked if I wanted to remove the program when started. I declined, and uninstalled the second SoA installation - which went, as far as I could tell, ok - however, it is possible it might have made changes to the registry - again, I am not sure if this would be or not the cause of the problem, but I thought I would mention it here in case it is relevant.

Edited by DragonRider
Link to post

Suggestions, please?

 

Addition: ... in case it is relevant.

Yeah, it is related.

The suggestion is the OBVIOUS, make a new SoA install, then install the ToB on it and vola. Then if you don't want the the old SoA install folder, delete it. Or don't... it doesn't matter.

Link to post

Hmm, thanks for the suggestion. :)

 

The trouble is, how to make the new install, if running the setup file from the disk results in it detecting the installed game, and asking if I want to remove it (but ending up not removing it), instead of beginning a new installation?

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...