Jump to content

weird red flames [help plz]

Guest Bijou666

Recommended Posts

Guest Bijou666

I posted this originaly in the BioWare Forums in the Baldur's Gate II Gameplay (Spoilers!) board, and someone told me i should try, here, any help, would be greatly appreciated ;) :



everytime i click to enter a different area the main character has a cricle of flame wosh up, its very annoying here are a few screenshots:






im currently in the underdark completing quests n the drow city, here is what my main character is wearing if you think something is affecting something else:


-drow full plate

-bracers of def ac7

-dragon helm

-battle axe +3 frostweaver

-ring of free action

-fortress sheild

-ring of regeneration

-boots of speed

-belt of inertial barrier


in my quick items i have :

-potion of extra healing

-black spider figurine

-silver horn of vahala


my char has:

-resist fire/cold

-protection from electricity

-free action



-magic resist


and i turned into the slayer in the tavern (ust natha) when i was dueling someone (1 on 1), and then when i killed her, i was brought out of the dueling ring and was changed back from the slayer automatic, and not by me doing it, could that be the cause?


and it only does that if i click on the entrance to a door or other area (somewere were it has to load)

any help is greatly apreciated,


Link to comment
Sounds like a 'Play 3D Effect' with the wrong timing mode has been applied to your character at some point.
Except the lighting effects are also running. I may get time to look into it, but I don't think there are any relevant issues with the default change back spell.


Anyway, this did happen because of the slayer change. If it doesn't go away after using CTRL+R (if you're running ToB with cheat keys enabled), try removing your ring of regeneration (just to make sure it's not another persistent effect showdown) and ring of free action and resting. If it's still running afterward, the easiest thing to do would be to reload from a save before the fight. And not turning into the slayer this time would help! :)

Link to comment

I think this would be from the change back. And there shouldn't be any way the lighting effects would get attached to the CRE. That it occurs when loading areas tracks with instances where the game reapplies effects, though; it would be interesting to see a saved game from this to see what exactly went wrong, but the quickest fix is always to reload.


Of course, there are about 500 different slayer changes, so it's hard to track from memory which ones run and when (does the actual ability button spell also have visuals? I can't remember).

Link to comment

Well, spin810.spl (GIVE_SLAYER_POWER) has this effect:

Type	Play visual effect (215)	ca h
Target	Self (1)	cc h
Power	0	cd h
Unknown	00 00 00 00 h	ce h
Play where?	Over target (unattached) (0)	d2 h
Timing mode	Instant/Permanent until death (1)	d6 h
Dispel/Resistance	Not dispel/not bypass resistance (2)	d7 h
Duration	60	d8 h
Probability 1	100	dc h
Probability 2	0	dd h
Resource	SPFLESHS.VVC	de h
# dice thrown/maximum level	0	e6 h
Dice size/minimum level	0	ea h
Save type	( No save )	ee h
Save bonus	0	f2 h
Unknown	00 00 00 00 h	f6 h*


Though that's not FIRE_CIRCLE, and should only be timing mode: Permanent Until Reload.


* used courtesy of devSin Near Infinity productions


// edited to add stuff


Ah, okay. I think that one's spin822.spl, which has sppolymp.vvc and polyback.vvc attached, but they're both timing mode zero duration 3. I've never seen anything like that stick around after a reload either.

Link to comment

That looks like the GIVE_SLAYER_POWER give the special ability to Player1 spell. I was talking about the spell that sets the variable so that the "do you want to be evil?" dialogue comes up, whichever one that is.


Detached visuals don't need a duration or timing mode (they just run once as specified by the VVC and get dropped).


Ah, okay. I think that one's spin822.spl, which has sppolymp.vvc and polyback.vvc attached, but they're both timing mode zero duration 3. I've never seen anything like that stick around after a reload either.
Yeah, that sounds right now. It also has the holy light or holy might or red holy might projectile, I think (which looks really stupid with the polymorph visuals).
Link to comment

i dont have a save file of before that specific fight, since someone told me it would go away so i continued and im now in the elven city, its been doing it ever since, i just edited the bladur file to add cheats and tried ctrl+ r and it worked, thanks everyone for the help, ;)

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...