Jump to content



Recommended Posts

I've just played through Coran's quest, and while the quest itself is nice, the fight at the end isn't - she's just too much for a BG1 level party, beyond "challenging" and right into "annoying" territory. Immunity to +2 weapons means the player needs to have already done Durlag's Tower and use a few very specific items to be able to hurt her in melee, fast regeneration, 30% MR and etherealness pretty much kill any chance to hurt her with spells, and level drain simply cannot be undone in BG1, leaving the player with the only option of CTRL-Ring his charachters (and being hit more than once is a death sentence - Kagain bravely withstood 3 hits before dying). Personal suggestion: tone her down a notch; fast regeneration and energy drain abilities are, imho, out of place.


Edit: I just noticed that MR gets bumped to a ridiculous 75% after she goes ethereal... CTRL-Y is all this thing deserves.

Link to comment
Guest WVN777

I'm playing BG1 NPC Project version 18, and the immunity to +2 weapons appears to have been addressed. First we charmed Coran with Algernon’s Cloak to bring him back over to our side, then we surrounded Amelia with Coran (Spider’s Bane +2), Yeslick (Bassilus’ War Hammer +2), Safana (Graywolf’s Long Sword +2), and Imoen (Zargal’s Short Sword +2). Coran hit twice for 24 damage and Amelia went Ethereal. She didn’t regenerate completely while Ethereal, she returned still injured. Imoen hit twice for 19 damage, plus the mage PC nailed her with the Wand of Frost, and Amelia fell. Amelia is still quite a challenge, but not impossible.

Link to comment

Speaking of Amelia, my quest got broken. I told Amelia that her story was suspicious, and Coran left me to help her. I entered Firewine, talked to Natan to get the truth, then attacked Amelia.


I killed her and reported to Natan, but Coran is still under her charms, saying he loves Amelia. Is there a variable I can alter in Shadow Keeper to bring him to his senses? :cringe:

Link to comment
We fix the level drain issue by editing the temples to allow restoration
Truth be told, I think you should not do so, because you fill every temple with Resurrection and Greater Restoration among the other. Which imo has nothing to do with NPCs themselves.

Add Lesser Restoration (and maybe a Restoration scroll or two) to FAI, Beregost and BG, if there aren't any, that should be enough.

Link to comment
Guest_ZG: What exactly is he saying? I am trying to look up the variables for you.

He's saying...

"Amelia... I adore Amelia..."

Then, he walks off to the Firewine Ruins, enters it, and re-appears outside where he was before.


I tried the quest again, same results. Entered Firewine Bridge via the ruins, Coran talks about ghostly women, Amelia spawns next to us in her usual spot, I press her for info while Coran goes head-over-heels, I turn her down as "suspicious", Coran goes blue-circle and Amelia says she's sorry for breaking up our fellowship.


I enter the ruins, meet Natan, ask him what's up (and get the long-winded version of his tale), tell him we'll deal with Amelia since she charmed one of our own, then we confront Amelia.


It's important to note that Coran does NOT go red-circle on me when I take this route: he remains blue-circle.


I attack Amelia and slay her, taking her ring and robe, then report back to Natan. No matter whether I take his potions or let him go empty-handed, Coran remains charmed. No charm spells work on him, no Algernon's Cloak, nothing.

Link to comment

I should add that I tried out both the "good" route of taking the flowers to Beregost and revitalizing them and this one, and the Beregost-route works as intended.


I think the problem lies in the global variable "X#CORANCHARMED", which on the Beregost route was put at 2, but on my route, remained at 1. I edited this variable via ShadowKeeper on my "broken" save to 2, and when I spoke to Coran, he talked as if I had tried to remove him from the party. I told him to stay with the group, and he's back with me as normal.


Maybe a script in the mod pertaining to Coran's quest is not working as intended.

Link to comment

Guest_ZG: Would you be so kind and post your weidu.log (in the main game folder, to be open with any editor) and post the content here. The "uncharming" of Coran should have happened in the FireWine area, but appearently something blocked the script block to trigger. I would like to know which mods you installed so I can check what is causing this.



Link to comment

And the quest outcome doesn't make much sense. I don't want to help a demon, so I killed it. But it dropped a very nice ring. Why would I give to the thief just to "prove" that it's dead? I told him that he may go, there's no danger. If he doesn't believe me, let him stay in dungeon. I'm keeping the ring to myself.

In the end I ctrl-q'ed the thief and dismissed him just so there he wouldn't force grab the ring from me. After that, ctrl-q'ed Coran, too.

Link to comment

This is my first post and I wasn't sure to post this but I noticed this thread was on the first page so I felt like I'd post it here.


I got a separate issue with this. Quite simply I pursued the option of talking to the thief, I then talked to Amelia and decided I'd rather kill her and initiated this through conversation. After reloading a couple of times (I found the fight tough but thats okay) I eventually managed to kill her through Minsc's incredible berzerking strength.


However here is the issue, after taking the loot, handing the ring to the thief, gaining the potions as reward. The quest simply stays in my journal. I did the entire firewine dungeon (read: headache) since then and so I am unwilling to reload an older save (actually I don't have one anymore) to fix this. I can't recall if I actually got the quest exp either, probably not as it is still in my journal.


Is this a common glitch and is there a console command or a way in shadowkeeper to fix this?


Also my Coran returned to me as usual, no issues here and in response to the last post, the idea of actually keeping the ring seems pretty nice too.

Link to comment

Welcome to the forums!


It would help tremendously if you could quote the journal entry that stays in your journal, so we can identify it.


If the journal entry is your only concern, I think it is possible to edit the journal and delete it. If you are worried about whether the quest is actually finished or no, than I'll have to pass as I don't know the quest that well, but would have to look into the code.

Link to comment

Thanks for the welcome and the timely reply. I have typed the journal entry below (out of curiosity was there an easy way than alt tabbing and typing it in manually?).




We have encountered a maiden, apparently betrothed to a thief, who is hiding from her in the Firewine Bridge ruins. Apparently, Amelia cannot enter the ruins, but she cannot depart the area, either until giving her fiance a "yes" or "no" response - in the form of white and red roses, respectively. We agreed to restore life to a bunch of withered roses for her, and give it to this wretch, Natan. According to Amelia, it will set her free from this vow."


As you can see the quest has not budged an inch, despite fighting her, Natan and Coran through dialogue and killing her, and giving the ring and gaining the reward of potions with him departing the area without issue.


I guess this quest is just stuck this way. Removing it from my journal as you suggest does seem like perhaps the only fix at the moment, I did not realize I could do that and honestly having it in my uncompleted quests/journal entry is what bothers me the most so I might be content to leave it at that and cheat to give any reward it would give if there is any. The most ideal outcome would be finding out if theres just something I've missed and need to do to fix this quest so I have it in my completed quest sessions but I'm not too hung up on that.


Idk if this matters much but for anyone trying to peice together this mystery, it is on BGtutu.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...