Jump to content

Mod conflict with Quest Pacl

Guest Clocknova

Recommended Posts

Guest Clocknova

There seems to be a conflict between the G3 Anniversary Mod and the Quest Pack from Pocketplane.net. The bard in the Copper Coronet who starts the G3 quest is missing his description and all of his dialoge. In it's place is a random bit of conversation from somewhere else in the game. Additionally, the same is true of the characters in the moneylending quest from the Quest Pack, one of which is also found in the Copper Coronet. I tried uninstalling both mods and reinstalling just one, and then just the other, but the characters from both mods are always there, even when their corresponding mod is not present, and their dialoge is still missing, even after reinstalling them, or after a complete reinstall of BG2 from scratch. How is this possible? And how can I get this problem resolved without starting over?

Link to comment

This sounds like you installed the Official Patch or ToB or something after a mod. If after reinstalling the people are still there with the mod installed it is because you are loading a savegame where they have already spawned, or something.

Link to comment

No, I installed the official patch, then the Baldurdash fixpack, then the mods, all of which were WeiDU compliant.


These are the Mods I have installed, all of which are on top of the latest ToB official patch and the Baldurdash Throne of Bhaal FixPack v1.12:


Ashes of Embers v19

Desecration of Souls v2.01

NPC Flirt Pack v1.01

OSX-G3Anniversary v1

OSX-G3Tweaks v6

OSX-NPCKit v0.72

Quest Pack v1

The Black Rose Part One v1

Unfinished Business v12

Virtue v15

Weimer-Ease of Use v28

Weimer-Item Upgrade v32

Weimer-Spell 50 v6

Weimer-Tactics Mod v21

Weimer-Underrepresented Items v2


Is there a specific order of installation for any of these? And is there anyway to get those characters to respawn correctly without starting over (AGAIN!)?

Link to comment

Usually when you find mixed-up strings like this, it means a mod was not able to access dialog.tlk because an editor was open or dialog.tlk gets overwritten.Another possibility is that the strings are in the savegame, and reinstalling mods in a different order will mix them. That being said, I am trying to duplicate the problem.


While unrelated to the reported bug, a preliminary investigation has discovered DoS overwrites the area script for the Five Flagons. This means is will be incompatible with G3A if DoS is installed after it.

Link to comment

Does this mean they will work together if I install DoS first? And are there any other mods in that list that need to be installed in a particular order or which are simply incimpatible with any other mods in the list?


I'd really like to have as much new material as possible in SoA this time around since I probably won't be playing through it again for a long time, if at all. This will be my fifth time through, and my first through ToB.


Thanks for your assistance.

Link to comment

Great, because both are great mods. It looks like I'm going to have to start the game over again, so I'm going to hold off doing another complete install until I can be sure something like this is not going to happen again. If anyone knows of any other conflicts in that list of mods, please let me know. Thanks.

Link to comment
Guest Clocknova

If you're trying to recreate the mixup, you should know that part of the problem may be due to the fact that I did a complete reinstall of the game and all the mods after I had started the pub crawl quest. I was having a problem with missing and out of place text in other areas of the game. For example: many items, most which were part of other mods, had no names or descriptions; Watcher's Keep on the map had a piece of dialogue instead of its proper name; and there was no text in the boxes you get after bootup where you choose between SoA and ToB. So I pulled my save folder, wiped my install, and started from scratch, but I don't think I installed the mods in the same order. I didn't think I had to. The dialogue in the pub quest was fine before the install, but messed up after. So, the original conflict may not have had anything to do with the Anniversary mod, but something else in that list was causing a problem. That's why I'm hesitant to reinstall them at the moment. I don't want to wind up starting the game over yet again.

Link to comment
Guest Clocknova

I'm also thinking that the "Check the Bodies" mod looks like it might be worth installing, but it's a pretty hefty mod. If anyone knows of any possible incompatibilities with this one, I'd love to know.

Link to comment
So I pulled my save folder, wiped my install, and started from scratch, but I don't think I installed the mods in the same order.  I didn't think I had to.  The dialogue in the pub quest was fine before the install, but messed up after.

Games saved when you had different mods installed/the same mods but installed in a different odd often (usually?) have messed up text. I'm afraid you may have to start a new game.

Link to comment
Games saved when you had different mods installed/the same mods but installed in a different [order] often (usually?) have messed up text.

Virtually always. Unless it's a mod without text strings, or you've left your dialog.tlk intact from when all the mods were installed.

Link to comment
Guest Clocknova

Thanks for all the tips. I guess I don't really understand exactly how WeiDU works, because I didn't know any of this. But I've been asking around and digging into various websites and readmes, and I think I've come up with a what might be a workable order for all of the mods I want to install. I haven't tried them yet, but I will shortly. Here's my new list; if anyone happens to spot a conflict, please let me know.


01. Weimer-Ease of Use v28

02. Weimer-Item Upgrade v32

03. Weimer-Spell 50 v6

04. Weimer-Tactics Mod v21

05. Weimer-Underrepresented Items v2

06. Ashes of Embers v19

07. OSX-G3Tweaks v6

08. OSX-NPCKit v0.72

09. Desecration of Souls v2.01

10. Unfinished Business v12

11. Victor's BG2 Improvements v1.2

12. TurnipGolem v1

13. OSX-G3Anniversary v1

14. Quest Pack v1

15. Ascension v1.4.17

16. Redemption-v1.2

17. The Black Rose Part One v1

18. BagBonus v1.0

19. Herbs & Potions

20. NPC Flirt Pack v1.01

Link to comment

You should have a file called WeiDU.LOG in your BGII directory - if you copy-paste the contents here, we will be able to tell.


EDIT: If that's not Ascension-WeiDU then that install order could be the cause of potential problems.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...