Jump to content

Strange problem after installing mods!


ShadowDragoon

Recommended Posts

This is a strange one. I started a new game on Baldur's Gate II earlier today, having recently finished up Baldur's Gate I. I imported my character, and ran through the dungeon a part of the way. I had some mods installed, and I got to the point where some drueregar killed my main character. I load up a saved game from earlier, and the strangest thing happened. The game freezes up for a minute, then shows all black instead of the area. If I wait a few moments, it shows the area, but my main character is unselectable. He has a blue circle around him (a different shade than the other non-joinable non-enemy characters), and none of my other party members are able to talk to him. I have full control over everybody else. I even tried pulling in a few charm spell scrolls to see if that would work, but they had no effect on him at all.

 

Anybody know what's the problem? If it will help, here is my installation order:

 

Baldur's Gate: Shadows of Amn

Baldur's Gate: Throne of Bhaal

BG: ToB official patch (newest version)

G3 BG2 Fixpack (without the OBC Additional Script Fixes)

Ascension

Unfinished Business

Expanded Thief Stronghold

Check The Bodies

Turnabout

Redemption

Desecration of Souls

Mordan's Christmas Mod

Ding0's Questpack

Imoen Romance

Weimer Spell 50

eSeries Scripts

gMinion Scripts

Wiemer Item

iiItem

One Pixel Productions

Divine Remix

Song & Silence

aVENGER's Rogue rebalancement

Weimer Tactics Mod

MTS Crappack

 

I had forgotten about the Crappack before. I used it so I could get all of the party's items on import, since I was tired of losing all of the good stuff. I thought that since I installed that last, that might be messing things up. But, I uninstalled that mod, and I still have my problem. I don't want to have to uninstall and re-install too much. I'm hoping somebody else knows exactly what the problem is.

 

EDIT: As requested, here's a link to a screenshot of the problem. The color is a bit washed out, but it's close enough to what it looked like in-game.

 

http://img.photobucket.com/albums/v121/Sha...oon/problem.jpg

Link to comment

Well it looks like your PC is under some sort of disabling spell, but unfortunately your cursor is over your portrait where those icons would be. Not that they always will show up necessarily, especially if this is a buggy spell effect introduced by some mod or other.

 

Just a random thought since I saw something similar in another forum... did you by chance charm your PC back to your control in the earlier saved game? Because if that's true, he will permanently be out of your control - this is hardcoded in the game engine from what I understand.

Link to comment

Nope. None of my characters have the charm spell. I consoled a few in hoping that would fix the problem after this happened, but it didn't have any effect on my character, even when the spell succeeded. Maybe I should have tried a dire charm instead...

 

The only icons on his portrait is a haste icon from a pair of boots of speed that stayed on him when I imported.

 

EDIT: Tried a Dire Charm scroll. That wouldn't work either.

Link to comment

It's one of those mods on your list which modify AR0602.BCS. I'm not familiar with all of them, so I can't tell which one for sure without having your copy of this file. The problem is in missing Continue() in script block extended using EXTEND_TOP.

Link to comment

What do I need to fix the file? Is there a program I have to download to go in and tweak the script? Or can I open it in Notepad? I'm no novice to programming, so I'll have an easy enough time following directions on fixing this.

Link to comment

Fixing the script now won't remove your current problem, it will prevent the same thing from happening in a new game.

 

Directions:

create a copy of any setup*.exe file in your BG2 folder and rename it to "weidu.exe"

- execute "weidu ar0602.bcs" from command line to decompile the script

- open the resulting "ar0602.baf" with notepad

- all script blocks above the one with trigger:

IF
 OnCreation()
 Global("NewGame","AR0602",0)
 Global("ENDOFBG1","GLOBAL",0)
THEN

must end with "Continue()" action (if they don't, add it).

- execute "weidu ar0602.baf" from command line to compile it

- put resulting ar0602.bcs into override folder

 

If you don't want to start a new game, the only option may be to edit your savegame with NearInfinity and change the value of area global "NewGame" in AR0602.ARE to 1. NI can also be used to edit the script instead of decompiling it and editing with notepad.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...