Jump to content

Green Water!

Recommended Posts

As far as I can tell, this crashes the Mac version. I tried doing the conversion on a PC here with the same results. Once you can find somebody else to verify, conditionalize it (see, I said something like WEIDU_ARCH would be useful).


Regardless, make sure you update the WED file so that the other tiles for the water are used (currently, it only uses tile 0, and doesn't animate). I'm currently doing this

 READ_LONG 0xa4 ~wallGroupsOffset~
 INSERT_BYTES ~%wallGroupsOffset%~ 0x0a
 WRITE_LONG ~%wallGroupsOffset%~ 0x00020001
 WRITE_LONG ~%wallGroupsOffset%~ + 0x04 0x00040003
 WRITE_SHORT ~%wallGroupsOffset%~ + 0x08 0x05
 WRITE_BYTE 0x062b 0x06
 WRITE_LONG 0x64 ~%wallGroupsOffset%~ + 0x0a
 WRITE_LONG 0x7c ~%wallGroupsOffset%~ + 0x0a
 WRITE_LONG 0x94 ~%wallGroupsOffset%~ + 0x0a
 WRITE_SHORT 0x0626 0x06
 FOR (index = 0x9c; index < 0xac; index = index + 0x04) BEGIN
   READ_LONG ~%index%~ ~offset~
   WRITE_LONG ~%index%~ ~%offset%~ + 0x0a

but Cam will come up with something more patchtastic.


I'm also doing WRITE_ASCII 0x3c ~WTRIV2R~ #8, so that it looks like bubbling green goo instead of stagnant exorcist vomit. You may want to do that if WEIDU_ARCH = ~osx~ (unless somebody cares enough to figure out why TIS2BG2 TISs crash the game).


Oh, and the Dagger of <CHARNAME> +1 isn't flagged as magical.

Link to comment

It works here as well. AFAICT, the only change other than the water is that there's now a 24-byte header for the TIS file (which it needs if it's not biffed). devSin, have you had problems with other TIS files in the override before?

Link to comment

I've never bothered updating or modifying the tilesets, but there are one or two that are in the override by default that work fine.


The crash occurs with both Sim's update, and an updated TIS/WED that I ran through TIS2BG2, so this is likely some obscure issue with the Mac version. I even tried deleting the header from Sim's file, but no luck.


make sure you update the WED file so that the other tiles for the water are used
I should qualify this by noting that this is the only area in the game that doesn't use all the tiles of the referenced tileset (every other area, including small indoor areas, use all 6 tiles for their water tilesets).
Link to comment

Has anyone tried running the AR0512 through DLTCEP's green water fixer to see if that has mac issues? That'll also play around with the wed so you may well have to write a new patch for that to include DLTCEP's fixes. Assuming it works.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...