Jump to content

SCS v32 Release Candidate (now Version 10) Available for Testing


Recommended Posts

On 1/1/2019 at 8:15 AM, Lilaina said:

Baresh (the werewolf henchman at Ulgoth's beard) spawns two werewolfs when turning. Is this intended?

No. Which version of the game?

On 1/2/2019 at 10:02 AM, Relay said:

elemental_area_immunity.tpa is deprecated with Spell Revisions  since v4. B15 on Enhanced Editions. The elemental damage array does not account for enemies with negative resistances. See Kjernon's quote here

Bascially adding opcode 324 to an effect using your array causes creatures with negative elemental immunity to also be immune to said effect.

Will look.

8 hours ago, Lord_Tansheron said:

But LoB puts everything on maximum natively? Or are there settings that aren't on max even if the difficulty is set to LoB? Random liches and HLAs on every caster seem like candidates.

LoB puts everything on max, yes.

Link to post

I'm using your the improved customization and management component and party members are being re-triggered to level up any time they are killed (so long as they have lower exp than the main character) 

This isn't a problem per se, except that HP seems to be calculated incorrectly after leveling up. I'm consistantly LOSING hp every time this happens. I don't have a good enough grasp on how HP per level is implemented to track down any solution atm sorry.

 

Link to post

So, I'm trying to install the latest (RC7) on a Windows XP virtual machine, and I'm getting an error that "SSL.exe is not a Win32 application" during installation. Am I right in thinking that SSL.exe no longer supports Windows XP? (I'm guessing it's a perl interpreter which embeds ssl.pl? Is there any workaround I could try e.g. by installing a Perl interpreter on system-wide and associating with the .PL extension or similar?)

Edited by AnonymousHero
Link to post
15 hours ago, DavidW said:

It's an executable built from a perl underlying script. I've no idea why it doesn't work on XP; can anyone reproduce?

It looks like ssl.exe included in RC7 is a 64-bit executable. It can't run on Windows XP (or any 32-bit versions of Windows Vista or later).

On Windows 7 or later you can check it yourself by right-clicking on ssl.exe. Select "Properties" and switch to "Compatibility" tab, the drop-down list of "Compatibility mode" should list Windows XP among other versions if it's a 32-bit executable, otherwise it will only list Windows Vista and later versions.

 

Link to post
4 hours ago, Guest drakul said:

Any chance of you adding the mod that actually tells you the spell someone is casting ?

No. (Can't you just install that mod?)

2 hours ago, argent77 said:

It looks like ssl.exe included in RC7 is a 64-bit executable. It can't run on Windows XP (or any 32-bit versions of Windows Vista or later).

On Windows 7 or later you can check it yourself by right-clicking on ssl.exe. Select "Properties" and switch to "Compatibility" tab, the drop-down list of "Compatibility mode" should list Windows XP among other versions if it's a 32-bit executable, otherwise it will only list Windows Vista and later versions.

 

OK, so I assume I should try to compile a 32-bit version?

Link to post
On ‎12‎/‎24‎/‎2018 at 7:37 PM, TheLoneTremere said:

Hey everyone, i'm someone who is using the iwdification component that is part of SCS and it seems we have a few issues that i'll highlight from my experience.

 

- Curse, Curse seems not to show up on the list of a cleric and if added manually to the list, it seems to cast with the stipulation that the caster is impacted as well as his enemies.

- Cat's Grace seems to be totally busted. The spell only gives 1 dex if at all to of any class. No rolling or anything.

- Emotion:fear, Doesn't work. It's suppose to provide thac0 penalties and dcreased AC, But it has no effects that go off and instead just acts like a melee spell forcing the caster to save for no effect, it's portrait on the menu is different from casting as well going from the broken red heart to a purple like shadow magic icon when it has been memorized. I've uploaded it here to see what you guys can do.

spwi411.spl

I can't reproduce any of this on v32 release candidate 7: all three spells work fine. The problem with Cat's Grace occurred on v32 release candidate 6 and earlier - are you using the latest version? (Because of the G3 downtime, version 7 was only advertised on Beamdog, so it's easy to miss it.)

The version of SPWI411 you have uploaded is very weird and makes reference to files that don't exist in vanilla BG2EE, IWDEE or SCS, so here (and perhaps with Curse too) I think you are probably encountering compatibility problems coming from some other mod. 

Link to post
7 hours ago, DavidW said:

I can't reproduce any of this on v32 release candidate 7: all three spells work fine. The problem with Cat's Grace occurred on v32 release candidate 6 and earlier - are you using the latest version? (Because of the G3 downtime, version 7 was only advertised on Beamdog, so it's easy to miss it.)

The version of SPWI411 you have uploaded is very weird and makes reference to files that don't exist in vanilla BG2EE, IWDEE or SCS, so here (and perhaps with Curse too) I think you are probably encountering compatibility problems coming from some other mod. 

 

 

Here is my weidu log, perhaps this will be a bit more clear. From what i am seeing, i can't find a version. I installed things via a BWS esque alternative ran by another person. My install took place on november 26 of 2018.

 

 

As to your latter comments, if emotion despair isn't add from this mod, hard telling where it came from. Maybe it was spell revisions but i'll have to ask and see maybe? 

WeiDU.log

Link to post

Hey, I'm trying to do a new install with the latest SCS RC and I'm running into some trouble.

Arcane IWD spells and more importantly the main component fail to install because they apparently can't find a translation for @9 (and on a previous try using the EE install tool I've gotten a similar error with a missing translation for @403)

 

 

SETUP-STRATAGEMS.7z

Link to post
1 hour ago, Ulb said:

Hey, I'm trying to do a new install with the latest SCS RC and I'm running into some trouble.

Arcane IWD spells and more importantly the main component fail to install because they apparently can't find a translation for @9 (and on a previous try using the EE install tool I've gotten a similar error with a missing translation for @403)

 

This probably has to do with the language you chose to install the mod on. The archive's debug file doesn't list the input, unfortunately... but you are installing a release candidate... by an author that is likely using English at typical installs, so they are likely to only provide a full .tra file for their own language, even if they could speak thousands of languages, requiring someone to update all of those is a task better left for outsiders.

But incase this was done in English... DavidW might have just had a mix of files and uploaded a wrong one. That happens often to everyone.

Also mixing old install files and new ones might cause this and so should always be avoided.

Edited by Jarno Mikkola
Link to post

I'm using English, the debug file should reflect that I think.(?)

Quote

Also mixing old install files and new ones might cause this and so should always be avoided.

What do you mean by that?

 

Link to post
39 minutes ago, Ulb said:

I'm using English, the debug file should reflect that I think.(?)

What do you mean by that?

1

Well, just the fact that one might extract an old version of SCS and then a new which overwrites files ... which could very well cause this. Not saying you did, but there's the possibility of that. As you didn't say you hadn't. 

The last point being my actual assumption of things that happened ... but as I have no evidence of that..it's the last point. 

Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...