Jump to content

Subtledoc's Random Tweaks


Recommended Posts

1 hour ago, Guest Bigby's Bitchslap said:

Faith and Powers mod with install option 3 (vanilla kits only) but I don't use the multiclass version because it did not allow Shamans to pick spells at the character level up screen (they only received their Shaman-exclusive spells)

If you install the Multiclass Shamans component (I think) and/or any sphere system, then Shamans will learn spells via an item ability under the backpack icon. Same aas with Tome & Blood's Multiclass Sorcerers, and with any sorcerers and shamans if you install Tome & Blood's 'Spell Switching' mod component. Hopefully the item ability is there and you just didn't realize it...

(I tested that, among a lot of other things, recently. But in my test I was using a sphere system. I hope it doesn't mess up shamans when no sphere system is used... I'll check.)

Link to comment
Guest Bigby's Bitchslap
1 hour ago, subtledoctor said:

Hopefully the item ability is there and you just didn't realize it...

I was about to feel very foolish. I was using AionZ's Warhorn Shaman kit to test the no-spells problem and it does have an enrage innate ability. However there is no special ability, quick slot or item that allows a shaman to pick spells when the no-sphere vanilla kits option is installed on the condition that the extra multiclass option is also installed. Oh and even for the vanilla "trueclass" shaman, its innate icon is greyed out at the beginning of play. I used the console to level up several times and the only spells that are added are the shaman-specific spells (vanilla for true class and Warhorn exclusive for AionZ's modded kit).

Also I can reproduce Sunscorch's icon being changed to Faerie Fire's icon now as well. Using the most recent version of SRR and your random tweaks, it's icon will be changed, even if those are the only 2 mods installed on a fresh installation.

Additionally, on a fresh EET install with only the aforementioned mods installed, Faerie Fire will be missing from the Druid list.

I guess @Bartimaeus is the person to notify?

 

Link to comment

Just SRR on BG2:EE, Faerie Fire is there, and Sunschorch's icon is correct. Installing the two Faerie Fire and Sunscorch components from this mod...did not result in Faerie Fire being missing from the spellist for me, but did result in Sunscorch having the wrong icon. This is because Sunscorch and Fearie Fire have their resource names (before being ADD_SPL-ed) switched between SR and SRR - I don't know why they're switched (probably something to do with before SR was ADD_SPELL-ized years ago), so I'll just switch them on SRR. Done...and that fixed it.

I would warn that while the Sunscorch component from this mod is fine (I think?) with SRR, the Faerie Fire component is not. The reason for this is because the Sunscorch does a complete replace of the spell resource, while the Faerie Fire attempts to patch the SR version of Faerie Fire, and the SRR version is quite a bit different from the SR version, so it's not going to patch correctly/in the intended way.

(e): Also, I would note that the Sunscorch component is creating this pointless linebreak after its first line in the description:

Baldur_PyEwKgitmZ.png

Edited by Bartimaeus
Link to comment

Hi, I installed SRR and 0.9 version of the mod(mainly for breach, pierce shield and haste/slow) some time ago and playing an EET run. I noticed there was some bug fixes what's proper way to go abut this considering i am in the middle of a run. Deleting all components with weidu then installing 1.3? I love both your and Bartimaeus's work by the way.

Link to comment

Ok,If it is something minor and breach works it is not a big deal. I just reached the level 5th level spells and breach become available I wanted to make sure it works as it is pretty much mandatory. 

Link to comment

@subtledoctor Nerogami on G3 Discord noticed the Wondrous Recall component could change the Potion of Insight description even if the potion itself was untouched (which could happen because @Bartimaeus's Spell Revisions Revised does not create potn43.spl but it adds the marker file, which exposes the accidental misplaced block).

Filed a PR to only update the item description if the spl is changed.

Edited by Graion Dilach
Link to comment

Tried to install the actual version 1.2 using a WeiDU 247 exe-file. I was only offered to install the slow-web component. Checking the tp2 there are some inconsistent */ and /* (so every component aside the slow-web was interpreted as comments) . I corrected the tp2 (see attached) and everything worked out. Maybe WeiDU 247 interprets the tp2 differently than the WeiDU version deliverd with the mod. 

d5_random_tweaks.tp2

Link to comment
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...