Jump to content
DavidW

Sword Coast Stratagems v33 now available

Recommended Posts

New release looks great!

One quick bug report. The lich that can spawn in the spellhold "level-dependent" undead spawn (by the vampire with the hand) casts "summon dark planetar" while insane-plus difficulty for Mage HLA is enabled. Which I believe shouldn't be possible as he is not one of the whitelisted HLA users in SoA, at least according to the readme. 

For what it's worth, I also think that particular lich shouldn't spawn in the first place until maybe 1.5mm exp, even on insane "level-dependent" spawns. It's just (imo) too tough for a level ~12 party with no gear, and way, way out of line with the challenge posed by the rest of the "insane" level content. Would be nice if that specific spawn required 1.5mm exp at insane or 1mm exp at insane-plus to spawn a lich. I think the other potential lich spawns are OK, as they are avoidable, although maybe they should be adjusted as well.

As it stands, feels like a player running insane difficulty is forced to either go to spellhold at less than 1mm exp, which is sort of weird and metagamey and cripples them for the entirety of the underdark, or cheese/exploit the fight. Also feels odd that a random spawn is ~10x more dangerous than the headline fight with Jon.

Maybe that lich has snuck in due to how the old install options got converted to the current slider/tuner system. Either way, feels very much like an insane plus spawn at 1mm exp because: its unavoidable, the party has no equipment, Imoen only has default spells, the party won't even have level 7 spells to cast ruby ray, etc.

Just my 2c. <3<3<3 this mod as always.

Share this post


Link to post

Thoughtful and helpful, thanks. I'll consider (and see if I can reproduce that Planetar).

Share this post


Link to post

Well, I tried installing v33 on my BG2EE game, but the Initialize AI component fails with ERROR: Failure("find_table_row: couldn't find a match").  Debug file attached.

Back to my backup, I guess. 😞

setup-stratagems.debug

Share this post


Link to post

@AngelIt looks as if some previous mod in your install order has done something odd to msectype.2da, and WEIDU's ADD_SECTYPE function is choking on it.  You have too many mods for me to guess which; could you post msectype.2da, and also do a change-log on it?

Share this post


Link to post

I've updated to 33.1. The main change is a shiny updated French translation, thanks to Jazira and Gwendolyne. This release also fixes a problem with spell hotkeys for high-level mage spells, reverts the mistaken mapping of hotkey 'D' to 'Q", and blocks a rare circumstance where liches would use Summon Planetar on too-easy a difficulty setting.

Unless you play in French, it's probably not worth reinstalling in mid game for this one.

Share this post


Link to post
52 minutes ago, DavidW said:

I've updated to 33.1. The main change is a shiny updated French translation, thanks to Jazira and Gwendolyne. This release also fixes a problem with spell hotkeys for high-level mage spells, reverts the mistaken mapping of hotkey 'D' to 'Q", and blocks a rare circumstance where liches would use Summon Planetar on too-easy a difficulty setting.

Unless you play in French, it's probably not worth reinstalling in mid game for this one.

You forgot to add new russian lines. ☹️

Share this post


Link to post
2 hours ago, Arkie said:

You forgot to add new russian lines. ☹️

So I did - sorry about that. I've amended 33.1 to include them.

Share this post


Link to post
4 hours ago, DavidW said:

It looks as if some previous mod in your install order has done something odd to msectype.2da, and WEIDU's ADD_SECTYPE function is choking on it.  You have too many mods for me to guess which; could you post msectype.2da, and also do a change-log on it?

This is my current setup with Stratagems v32.7 installed.

00000: /* created or unbiffed */ ~IMOEN_FOREVER/IMOEN_FOREVER.TP2~ 0 0 // Imoen 4 Ever in BGII: Experience the BGII without pressure - and with Imoen!Version 2
00001:  ~RR/SETUP-RR.TP2~ 0 1 // Thief kit revisionsv4.92
00002:  ~REFINEMENTS/SETUP-REFINEMENTS.TP2~ 0 10 // Revised High Level AbilitiesInstall revised HLAs for all classesbeta 4.23.1
00003:  ~STRATAGEMS/SETUP-STRATAGEMS.TP2~ 0 5900 // Initialise AI components (required for all tactical and AI components)v32.7
00004:  ~STRATAGEMS/SETUP-STRATAGEMS.TP2~ 0 6510 // Improved fiends and celestialsv32.7
00005:  ~STRATAGEMS/SETUP-STRATAGEMS.TP2~ 0 6560 // Smarter mind flayersv32.7
00006:  ~STRATAGEMS/SETUP-STRATAGEMS.TP2~ 0 8010 // Improved Shade Lordv32.7
00007:  ~ATWEAKS/SETUP-ATWEAKS.TP2~ 0 180 // PnP Mephitsv4.53
00008: /* acted upon in an undefined manner */ ~GENERALIZED_BIFFING/GENERALIZED_BIFFING.TP2~ 0 0 // Generalized Biffingv2.2 BWP Fix

Refinements is the most likely culprit, I think.  I'll see if I can do a test without it.

msectype.2da

Share this post


Link to post

Wait, so it installs fine with 32.7, but not 33? That's very weird. I'll think further.

Share this post


Link to post
6 minutes ago, DavidW said:

Wait, so it installs fine with 32.7, but not 33? That's very weird. I'll think further.

Mm, it's possible that a faulty version of msectype.2da has sneaked in somewhere during the work on my spell pack.  I'll try from a clean backup.

Share this post


Link to post

Also have a look and see if there's a copy of msectype.2da just loose in your game file. Looking at your log, these are the crucial lines:


[stratagems/spell/modify_breach.tpa] loaded, 2666 bytes
Copied [stratagems/spell/modify_breach.tpa] to [weidu_external/workspace/modify_breach.tpa]
[weidu_external/lang/stratagems/english/spell.tra] has 94 translation strings
[weidu_external/lang/stratagems/ENGLISH/spell.tra] has 94 translation strings
[MSECTYPE.2DA] loaded, 717 bytes
[./override/MSECTYPE.2DA] loaded, 480 bytes
Stopping installation because of error.

So: the modify_breach function loads correctly (those are the first four lines). The first thing that function does is call ADD_SECTYPE. Then it loads 2 sectypes - one is from the override, but the other is (I think, from a little testing) just in the main game directory. And they're different (different lengths). On my successful install's debug, it just (twice) loads the override copy.

Share this post


Link to post
12 minutes ago, DavidW said:

Also have a look and see if there's a copy of msectype.2da just loose in your game file. Looking at your log, these are the crucial lines:


[stratagems/spell/modify_breach.tpa] loaded, 2666 bytes
Copied [stratagems/spell/modify_breach.tpa] to [weidu_external/workspace/modify_breach.tpa]
[weidu_external/lang/stratagems/english/spell.tra] has 94 translation strings
[weidu_external/lang/stratagems/ENGLISH/spell.tra] has 94 translation strings
[MSECTYPE.2DA] loaded, 717 bytes
[./override/MSECTYPE.2DA] loaded, 480 bytes
Stopping installation because of error.

So: the modify_breach function loads correctly (those are the first four lines). The first thing that function does is call ADD_SECTYPE. Then it loads 2 sectypes - one is from the override, but the other is (I think, from a little testing) just in the main game directory. And they're different (different lengths). On my successful install's debug, it just (twice) loads the override copy.

Yes, there was a msectype.2da sitting in my main game dir (not override), probably left there from when I did a weidu --biff-get sometime to examine it.  (I needed to know how it works for implementing Repel Insects in my spell pack.)  Odd though that this would cause an issue, I thought weidu only looked in the biff files and override.

Anyway, I removed it and a few other stray files (mostly decompiled scripts), testing again now.

Share this post


Link to post

Hey! I just finished the basic BG1 and am very excited to play BG2 with SCS! I have my character ready to import and started installing!

The reason I am posting is because I ran into an error. The install.exe for stratagems couldn't read/access a file. It was around the Drow section of the install. I decided to close and skip back to that part with administrative privileges to see if it helps. I found that even when I select n or N for no changes, it still drops and reinstalls that portion with no way to just skip back to where I was at. This is causing the install process to be, in my opinion, unnecessarily long.

 

Maybe there is a way I can just skip back to that part and just don't see it? If not, I really wish there was, because as this long process of updating files is happening, I still do not know if that file is going to have problems again with administrative mode.

Share this post


Link to post
Posted (edited)

Under improve minor encounter, this is the error that came up:

Installing file(s) dw#dkmg1.baf dw#dkmg2.baf
Compiling 1 script ...
Compiling 1 script ...

SFO: Applying patch(es) to CRE file(s) spmugg2...

...done

SFO: Applying patch(es) to CRE file(s) spmugg spmugg3...

...done

FATAL ERROR: Sys_error(".\\lang\\en_us\\dialog.tlk: Permission denied")

Ugh, Should I try to just uninstall that part? I think I was almost done.

*Edit: Looks like that file had read only permissions as the user I am logged in as, maybe that caused this? Trying again but it takes a while to get back to that point.

*Edit2: So... the first reinstall I said Yes to the first 4-5 questions which even when I press 'N', caused a full reinstall of each section. When I pressed only Y to the tactical section, pressing N skipped the various sections. So, maybe it had to do with using a lower case n on the first option, or possibly just from saying y to the first few sections caused a full reinstall. 

Looks like the minor encounters was the last section, and it worked this time. I am all set!

 

Edit3: I tried to reproduce the issue, but now each time it properly skips when I say 'No Changes'. Is there a log file for previous installs?

Edited by Slick85

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...