Jump to content

Lurker's EET install: eet-modpack_2023-09-17_v1 (was: Passive Black Talons?)

Recommended Posts

(EDIT: follow-up)

I'm not sure if this is actually caused by stratagems, but since this mod has a component that is dedicated to Black Talons, stratagems is currently my first suspect.

Game version is EE + EET.

I discovered larger groups of Black Talon bandits on several maps, that were completely passive, sometimes only spawning from out-of-sight and walking to a "rally point", where they happily waited to be cloud-killed, for example. There were also some passive "Bandit Guards" (don't remember exactly how they were called) on some maps. Curiously enough, some very few Black Talons weren't passive.

Don't know if related at all, but I also discovered a "Poison Mist" at least twice (the second one on the first level of Watcher's Keep, the first one on some overland map in the earlier BG chapters - though those are on separate games on the same game installation), which does nothing at all, and has no dialog ("Poison Mist: has nothing to say to you.").

Installed mods that also (might) fiddle with creature scripts are D0QUESTPACK, MIH_EQ and FIX_CRE_SCRIPT_NAMES (needed to fix MIH_EQ), from what I can tell. I also explicitly don't use the advanced AI from stratagems.


Edited by Lurker
renamed topic / invalid bug report
Link to comment

Black Talon Elites are normal enemies with generic combat scripts, that are usually created by spawn points in certain wilderness maps. There's no reason for SCS to change that; the general AI upgrades tweak their combat scripts, the tactical component gives them a level so they're immune to Sleep, and there are spots where SCS adds some to other encounters that might have additional scripting (Bandit Camp, Davaeorn). But they'll still be normal enemies with standard "ranged attacker" combat scripts. If you're seeing something else, it's definitely another mod that altered them.

Link to comment

From past experience, MIH_EQ is my goto suspect for breaking creature scripts or dialog, as long as there are no other pointers. So the Poison Mist seems to fit that negative bias.

I just entered Amkethran, and was "approached" by a halfling named "Tony". This one has nothing to say at all when being clicked on, and also failed to initialize dialog in the first place. From what I got when looking at his DLG, which mentions Shadow Thieves and "Aran", he seems to not really belong here at all. So I neither know from which mod he originates, nor what caused him to be in the wrong game.

*sigh* This game makes me go double OT in my own topic.

Link to comment

The poison mist thing is a known bug in MiH E&Q, stemming from the fact that the same creature (mistpo01) is used both as a summon and as a random encounter by the base game.  It's fixed in the current master, and the upcoming EE Fixpack will address the ambiguous mistpo01 situation.

As for the Black Talons, I'm fairly certain I have nothing to do with that one, I don't do anything with them at all.

Link to comment

Since this bug report seems to be invalid and I just hit a game breaking bug that I once again can't contextualize, I decided to rename the topic. If a mod could move this somewhere better fitting, please do so. @jastey?

So far, thanks for the feedback.

I'm currently stuck after the first combat at the Throne of Bhaal. This is a game that I started directly in ToB, to take a break from my current game, and also because I was curious if it's even worthwhile to continue with this setup.

So far, the most annoying thing was that Viconia skipped some lovetalks, so that I had to change her variable to experience the alignment change, which worked out so far; so this was more of only a minor annoyance, perhaps caused by my habit of spamming wish rest. (Personal quota - number of successfully completed romances at the end of ToB - without them bugging out somewhere in between - since the original game came out: 0)

This game has LongerRoad Irenicus in the party. From his dialog, it seems I managed to commit him to accept a soul offered by Ilmater after Sendai's Lair. During Amelyssan's  initial villain speech, Irenicus stayed loyal to charname.

I also have Sarevok in the party - class changed to Blackguard via NPC_EE - and think that I've chosen every option to encourage him to chang his alignment (SAREVOKCHANGE is "4"), but he's still chaotic evil, and also just gave an evil dialog when idling at the Throne. Why didn't he change his alignment? Shouldn't this happen right after his "I... I see." remark after his third conversation?

I've completed the first fight, against Bodhi and 4 Fallen Solars, then waited for Imoen to become "normal" again, and accepted her back into the party. And that's it, the game doesn't progress anymore. The platforms aren't accessible via walking, and also cannot be activated after "CTRL-J"-ing there. The only thing that happens are banter dialogs from time to time. I'd appreciate any hint for how to hot-fix this via console commands in game, if someone here (@AL|EN?) is familiar enough with LR?

I've no clue what's wrong with this setup in general, and what breaks what. Some spells and journal entries have unfitting strings; I also needed to fix some item descriptions by adding 200.000 to the dialog/string reference, which from what I've learned so far points to some mod having an issue with EET-style dialog references? (Hint: Had this with Baeloth's ring, for example.)

Since I usually try to give useful feedback to identify/report/improve bugs, for now I'm completely at a loss, and once again somewhat frustrated.

Btw, LongerRoad so far is also the first mod, where I repeatedly experienced text encoding errors in game, I guess when a line of text contains backticks. The "file" command (I'm on Linux, and run the game via Wine) says that 32 of the mod's TRA files are in "UTF-8 Unicode text", while 94 are "ASCII text" - I recently read somewhere that text should be in ANSI? So is there an "invalid" conversion from UTF-8 when weidu processes those files via iconv or some such? I get comparable malformed text in game and when viewing the corresponding TRA either on the CLI or in vim; viewing the file via Github's web interface just shows the backticks. (Example: LRIRENIC.TRA; @64, @65, @75)

Edited by Lurker
trying to be more comprehensible
Link to comment

Okay, now I'm 99% sure that Longer Road is responsible for this mess.

Out of curiosity, I loaded a save where my party is still in the Pocket Plane, right before the final combat, but with my newer installation.

Tadaaa, the regular Ascension kicks in, and the platforms are connected by those energy beams. And I get a combat with Irenicus vs. Irenicus.

Bah, I should just browse the text for the Longer Road epilogues, and then finally kill this mess.

Link to comment

I couldn't give it a rest and tried to figure out how to at least trigger the epilogue sequence by more or less blindly poking DLGs for Actions that I tried to run via Eval().

In the end it was simply enough to

  • have FINMEL01 idling on the map
  • summon FINSOL01 and talk to it

Bam, problem "solved".

I even got the "good" ending for Irenicus, on the first (AND LAST) try with Longer Road. Since I now know about the "Tree" view for DLG in Near Infinity, I also could figure out the other endings.

I also noticed that Sarevok was actually shown as CG in Near Infinity, but still CE in game. He had a permanent effect that forced his alignment to CE. After deleting this effect, I got his good epilogue.

This game is weird.

Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...