Jump to content

Subrace mod


Recommended Posts

Guest Feniks

Hopefully can be fixed, im playing a Drow, whenever i go indoors during the day, i get a repeated message that "Unaffected by effects from" which essentially seems to be the blindness being countered.

Link to comment
11 minutes ago, Guest Feniks said:

Hopefully can be fixed, im playing a Drow, whenever i go indoors during the day, i get a repeated message that "Unaffected by effects from" which essentially seems to be the blindness being countered.

Well, one way to do this would be to remove what ever is done by default and then add the effect to the area via it's script. And that would need to check if the area is outdoors area before it adds it in, not make the script check if the area is outdoors one ... this of course requires a few things I am not complitely aware of... like for example the BG2Fixpack if you play the vanilla non-EE BG2.

Link to comment
Guest Feniks

As far as i can tell, there is a custom spell called SRDBLIND which is pulsed every 6 seconds, and it checks for outdoors and time of day. If not outdoors OR not day time, then the effect is applied, otherwise its removed.

Beyond that i cant get the spell files to open in Near Infinity, so im pretty much stuck. For now im just going to remove the effect entirely in EE Keeper to remove the text spam.

Link to comment
On 5/14/2021 at 2:55 AM, Guest Feniks said:

Hopefully can be fixed, im playing a Drow, whenever i go indoors during the day, i get a repeated message that "Unaffected by effects from" which essentially seems to be the blindness being countered.

Never seen a problem like this. I do not have any messages. It’s strange.

Link to comment
Guest Feniks
1 hour ago, tipun said:

Never seen a problem like this. I do not have any messages. It’s strange.

Just got Viconia and she has exactly the same problem.

Link to comment
1 hour ago, Guest Feniks said:

Just got Viconia and she has exactly the same problem.

Perhaps some other mod changed something? I tested on SOD, BG2, EET and IWDEE. It never happened.

What version of the game? I have 2.5.17.6. I don't have version 2.6, so I can't check it there.

Link to comment
On 15.05.2021 at 20:37, tipun said:

Perhaps some other mod changed something? I tested on SOD, BG2, EET and IWDEE. It never happened.

What version of the game? I have 2.5.17.6. I don't have version 2.6, so I can't check it there.

In version 2.5.17.6 everything is fine, but in version 2.6.5 begins spam messages, we will wait for the fix ... Maybe there are considerations how to fix it?

Edited by Fauls
Link to comment
On 5/23/2021 at 11:35 PM, Fauls said:

In version 2.5.17.6 everything is fine, but in version 2.6.5 begins spam messages, we will wait for the fix ... Maybe there are considerations how to fix it?

I do not know now. I don't have version 2.6+. And I can't say exactly when it will be. Therefore, I cannot check yet.

Link to comment

I finally made it to BG2EE version 2.6.6.0. I will try to fix the problems that arose with this version of the game.


@Guest steve
I don't quite understand what is meant by ancestry (my English is poor). I took all subraces from IWD2, and when I create new ones, I will need the help of the Internet community. I'm still closer to GURPS in board games than to DND. And I would like to clarify the question.

@Endarire

When the version of the game was 2.5.16.6 the mod was compatible with the games BG1EE, BG2EE, EET and IWD1EE. I received version 2.6.6.0 of games only yesterday. I will check. But I think that it will also be compatible with all the games of the new version. I skimmed the ui.menu and the changes are not very big. After all, the code of my mod is looking for places that seem to have already remained unchanged.

Link to comment
Guest Steve
16 hours ago, tipun said:

I finally made it to BG2EE version 2.6.6.0. I will try to fix the problems that arose with this version of the game.


@Guest steve
I don't quite understand what is meant by ancestry (my English is poor). I took all subraces from IWD2, and when I create new ones, I will need the help of the Internet community. I'm still closer to GURPS in board games than to DND. And I would like to clarify the question.

@Endarire

When the version of the game was 2.5.16.6 the mod was compatible with the games BG1EE, BG2EE, EET and IWD1EE. I received version 2.6.6.0 of games only yesterday. I will check. But I think that it will also be compatible with all the games of the new version. I skimmed the ui.menu and the changes are not very big. After all, the code of my mod is looking for places that seem to have already remained unchanged.

It's a concept from later editions of D&D, (mostly 5e, and has a mechanical role for Sorcerers). In D&D, dragons can assume a human/humanoid form, and the source of a sorcerer's magical aptitude is due to having an ancestor that wasn't human.

However, this doesn't mean that all descendants of dragons (or anything else) are required to, mechanically, be a sorcerer. 

Half-dragons had playable statblocks in earlier editions of D&D, but I'm asking if it would be possible to add those, but rebrand to "Dragon Ancestry" for flexibility of RP.

Sorry to confuse you.

Link to comment

@Guest Steve

Thank you for the clarification. I will study this material. And I'll see what I can do. If possible.

And no need to apologize. On the contrary, you gave me new food for thought.

Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...