Jump to content

Sword Coast Stratagems v33 now available


Recommended Posts

OK. For some reason the operating system (on your system, but not mine) isn't allowing WEIDU access to 'gtimes.ids'. I can't see why that would be, though. At the risk of sounding like every computer helpdesk ever, have you tried restarting your computer? That might break whatever lock it's got. Failing that, try deleting gtimes.ids and replacing it with a blank file. (SCS will fill in all the details it needs anyway.)

Link to post
1 hour ago, DavidW said:

OK. For some reason the operating system (on your system, but not mine) isn't allowing WEIDU access to 'gtimes.ids'. I can't see why that would be, though. At the risk of sounding like every computer helpdesk ever, have you tried restarting your computer? That might break whatever lock it's got. Failing that, try deleting gtimes.ids and replacing it with a blank file. (SCS will fill in all the details it needs anyway.)

I have tried restarting the computer, tried deleting gtimes.ids and replacing it with a blank file, tried simply deleting it and tried uninstalling most of my mods, but no luck. I have even tried uninstalling the game completely and running 'setup_stratagems.exe' on a clean install (only the 'initialize AI components' part of the mod). In all cases, it gives me the same error. However, when I follow the prompts after running 'stratagems-33.5.exe' (not 'setup_stratagems.exe' directly from the game folder), i get a different one:

ERROR Installing [Initialise AI components (required for all tactical and AI com
ponents)], rolling back to previous state
Will uninstall   4 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
Uninstalled      4 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
ERROR: Sys_error("override/spell.ids: Invalid argument")

Please find the debug file attached. At this point, I'm not sure what else I can do.
SETUP-STRATAGEMS.rar

Link to post

I've found another minor issue: In Abazigal's lair lizard man shamans cast "cast previously" spells when the fight has already been going on for a few rounds. The spells cast this way are Magic Resistance, Barkskin and Mirror Image. I understand that this shouldn't happen, if I'm getting it right all the "cast previously" spells should be cast at the very beginning of the fight.

Edited by Alonso
Adding info
Link to post
6 hours ago, desmond_lochart said:

I have tried restarting the computer, tried deleting gtimes.ids and replacing it with a blank file, tried simply deleting it and tried uninstalling most of my mods, but no luck. I have even tried uninstalling the game completely and running 'setup_stratagems.exe' on a clean install (only the 'initialize AI components' part of the mod). In all cases, it gives me the same error. 

If you're getting that error when trying to install that component on a clean install, I'm afraid I can't help you, because on my machine it installs fine, and ultimately I can't fix something I can't reproduce. I think these error messages mean that your OS isn't letting the mod have access to the files it needs to access, but I've no idea why that might be. Maybe try installing the game somewhere else on your HD?... I'm out of ideas, sorry.

Link to post
7 hours ago, DavidW said:

If you're getting that error when trying to install that component on a clean install, I'm afraid I can't help you, because on my machine it installs fine, and ultimately I can't fix something I can't reproduce. I think these error messages mean that your OS isn't letting the mod have access to the files it needs to access, but I've no idea why that might be. Maybe try installing the game somewhere else on your HD?... I'm out of ideas, sorry.

Thank you for putting time and effort into trying to solve this issue! Your comment was actually very helpful. After fiddling with mod files for quite a while, editing the one responsible for gtimes.ids and having the installation fail at another place with a similar error, I have finally figured out the cause. Apparently, my antivirus sometimes deletes the files generated by the mod during installation process before those files have a chance to be used. However, it never gave me any warning messages, which is why it took so long to figure out the cause. At any rate, after temporarily disabling it, I was able to install the component without any issues.

Now I'm looking forward to enjoying SCS. Hopefully, AI improvements will provide a greater tactical challenge and better convey a feeling of playing with a cruel, but fair DM. On another note, the Balduran Isle might actually become fun now (I enjoyed the Durlag Tower in original, but the Isle left much to be desired). Thank you very much for creating this mod and supporting it for such a long time!

Link to post
Guest Rudolf289

Smarter beholders component fails to install on BG2EE v2.5.16.6 due to the following error:

SFO: Installing and patching SPL file(s) dw#betel => spin176...
Copying and patching 1 file ...
[STRATAGEMS/beholder/resource/dw#betel.SPL] loaded, 442 bytes
ERROR: No translation provided for @100
ERROR: No translation provided for @100

ERROR: Not_found in apply_standard_function: inputs were func=say_name, arguments=100
ERROR: [STRATAGEMS/beholder/resource/dw#betel.SPL] -> [override/spin176.SPL] Patching Failed (COPY) (Not_found)
Stopping installation because of error.

Here's the debug file: https://ufile.io/je4st6ag

Link to post
58 minutes ago, DavidW said:

Can I have your weidu.log?

Sure. Below is a zip with the weidu.log and the SCS debug file. The error appears first in the Improved Shapeshift component, but is not fatal, and then explodes in the NPC customization.

I should add that this is a regression as with SCS v33.4 and weidu 246 everything installed fine.

log_debug.zip

Edited by grodrigues
Additional info.
Link to post
49 minutes ago, Guest Rudolf289 said:

Smarter beholders component fails to install on BG2EE v2.5.16.6 due to the following error:

SFO: Installing and patching SPL file(s) dw#betel => spin176...
Copying and patching 1 file ...
[STRATAGEMS/beholder/resource/dw#betel.SPL] loaded, 442 bytes
ERROR: No translation provided for @100
ERROR: No translation provided for @100

ERROR: Not_found in apply_standard_function: inputs were func=say_name, arguments=100
ERROR: [STRATAGEMS/beholder/resource/dw#betel.SPL] -> [override/spin176.SPL] Patching Failed (COPY) (Not_found)
Stopping installation because of error.

Here's the debug file: https://ufile.io/je4st6ag

Are you installing directly, or using PI or some other auto-installer?

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...