Jump to content

Recommended Posts

Okay, I played Tales of Anegh, and after ending it, I was moved directly to chapter 21. But I was in waukeen's promenade, having just left Irenicus dungeon when I accepted the mission. Basically, I'm in ToB now. Do you need anything at all to see if this 'issue' can be fixed? Nothing too gamechanging given that I'm not going to play it anymore anyway.

Edited by Arthas
Link to comment

Thanks K4thos for the heads up. I'll be honest, I tried to register in that forum but she banned me. As such, I'll post my queries here. There is a chance she will read what I write anyway.

By the way, I didn't forget about you asking for the savegame. I'm just a bit busy at work. I'll try to replicate the issue, and if I can do it, I will actually publish the savegame.

Link to comment

the mod wild mage additions lacks the following (and useful) component:



       Some people seem to have a problem with a lone level 1 mage having to run

         away from a vastly overpowered opponent. Still, the same people love to rest

         in the wilderness right after Gorion's dead.


         If you're one of them, install this component, it will prevent Rhialto from

         showing up after resting outside in BG1-Tutu and the BG1-Part of BGT.

         Instead, Rhialto waits for you on a fixed position outside Candlekeep's walls,

         you can face him on your own terms.


         Just remember: Rhialto was never meant to be killed by an equal opponent.

         The whole mod and especially the confrontation was made for a 1st level Mage

         who just left Candlekeep, and you miss out the fun of the lower level Wild Mage

         spells when you confront him just before you go after Sarevok. 


Another thing - it seems that Rhialto should cast 4 spells, and the forth should turn him into a squirrel. That's why the author makes it possible to meet him at level 1, to show you the risks (and fun!) of being a wild mage. But it doesn't happen. My suggestion is to add into your fixpack a file to ensure the mod works as the author wishes and that no matter what, rhialto gets turned into a squirrel.

Link to comment

I've got a few questions:

1) in my current playthrough I'm using check the bodies. I saw people in the .net actually complaining for the chores you're supposed to do for that mod. There is a mod for BGT, Klatu Tweaks and Fixes, that actually make you skip these. So my question is thus: I didn't install Klatu, but I didn't play these chores. Were them removed in some way or retouched? I'm actually happy I didn't play them, not a critique, more a curiosity.

Edit: seems like the answer to question number 1) is here: http://www.shsforums.net/topic/59973-ctb-ee-v22-for-bg2eeeet-and-bg2tobbgt/?p=602664 

2) I'm going to register once again in your forum hoping to not get banned.

3) There is still no "Skip Chateau Irenicus" from Argent77: https://forums.beamdog.com/discussion/60934/mod-skip-chateau-irenicus
Also "Reign of Virtue" is missing: https://forums.beamdog.com/discussion/34075/freedoms-reign-reign-of-virtue-now-enhanced#latest

4) Would you kindly check if EET works well with Improved Temple Services of Atweaks? I've got them both installed in my playthrough and well... the results are not that good. Currently I've got the following services in the temples:

[Vanilla: as you can find them also in vanilla Baldur's gate]
Cure light wounds: 8 hp healed, 50 gp
Cure Serious wounds: 17 hp healed, 100 gp
Cure critical wounds,  27 hp healed, 200 gp

[Outcast: there are allso these two useless spells added that I don't think should be here at all]
Cure moderate wounds: 11 hp healed, 100 gp
Cure medium wounds: 14 hp healed, 150 gp

The cute thing is that I used cure moderate wounds and cure medium wounds instead of the "vanilla" spells and as such I lost a lot of money. I checked my mod list and it seems the likely culprit seems to be an interaction between atweak and EET. Any informations you need?

Edited by Arthas
Link to comment

Just a disclaimer:

This is the third by me updated SHS mod Roxanne declares as "completely bugged and unplayable" (without any further info, especially not to the mod maintainers.)

Last two times she did so, it turned out to be a lie.

Everyone is welcome to come to their own conclusions.


Link to comment

The tool installs the SCS IWD Spell components (1500 and 1510) as park of its tweaks section rather than the ai improvements section.

This means that enemy mages and priests (from the Smarter Mages/Priests components) and other creatures that COULD use them (like vampires) do not get assigned IWD spells in their spell choices.

Alterations to the spells are also part of the smarter mages/priests components leading to undesired spell behaviour (I think this is relatively minor though).

The IWDification versions of the spells ARE installed earlier in the sequence, so for the time being dedicated bws users should choose that mod instead of the scs iwd components (or try spell revisions, a much broader modification of the spell system that scs can also account for)

Link to comment

My own recommendation as to how to install SCS with this tool is: don't. The maintainer makes some very questionable choices and does not participate in discussion with me on any forum I have access to. Do it manually, or use Project Infinity.

If you must use it for your general install, I recommend leaving SCS (and probably Tweaks) out and installing them manually afterwards.

Link to comment
Guest GerPronouncedGrr

Hey folks, I'm trying to install EET using this tool for the first time, and getting an error. Since I'm new to this I'm not sure what to do about it, or why it's happening.

ERROR Installing [EET core (resource importation)], rolling back to previous state
Will uninstall 2767 files for [EET/EET.TP2] component 0.
Uninstalled    2767 files for [EET/EET.TP2] component 0.
ERROR: Not_found
PLEASE email the file SETUP-EET.DEBUG to K4thos (swit)
Automatically Skipping [EET core (resource importation)] because of error.
Using Language [English]
[.\lang\en_us\dialog.tlk] created, 300035 string entries

NOT INSTALLED DUE TO ERRORS EET core (resource importation)

D:\Programs\Steam\steamapps\common\Baldur's Gate II Enhanced Edition>

ERROR: cannot resolve trigger 0x40a8
ERROR: [EET/TEMP/PATCH/BCS/ACT03SK.BCS] -> [EET/temp/patch/baf/ACT03SK.baf] Patching Failed (COPY) (Not_found)
ERROR: Not_found
Enhanced Edition Trilogy (Enhanced Edition Trilogy) was not installed due to errors.

Without this component the installation cannot be continued.

You can try to repair the problem and install the component again afterwards. In this case please select "retry" after the repair.

If you don't want to spend time on that now, you can also exit the program.
Enter [r]etry or [e]xit.


Link to comment


ERROR Installing [EET core (resource importation)], rolling back to previous state

Says that the error happened before that ... so we cannot tell you what went wrong as you didn't copy paste the correct data for us to use. Which is why the above suggests that you post the ENTIRE setup-EET.debug file somewhere for people to look.


On 8/21/2019 at 4:22 AM, DavidW said:

If you must use it for your general install, I recommend leaving SCS (and probably Tweaks) out and installing them manually afterwards.

Thing is, you really can't. You fail to notice that the program to complete needs to install the EET_END, AFTER the other mods... usually. It's like you only view things from your own perspective. But you could give better recommendations ... like your own install order suggestion in PI, if you actually would care about other peoples installs. Suggesting PI as a better option, than none. Just like you really carred about the install order in BWP or BWS, ouh yeah, you didn't then either.

Edited by Jarno Mikkola
Link to comment
Guest GerPronouncedGrr

Sorry for pasting the wrong info. Actually, I'm not sure what file you're referring to. In my EET Tool Logs folder I have EE-Debug-Download, EE-Debug-Extraction, and EE-Debug-Installation. I don't see anything called setup-EET.debug anywhere. If I press 'Open Debug' from the EE Mod Setup Tool UI it references EE-Debug-Installation, which is about 15mb worth of text.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...