Jump to content

Recommended Posts

If you have a modded game and you want to continue playing it to the end, you'd better skip the update for now. It will overwrite most of your files and you must start a new game.

Hopefully you followed the instructions to have your modded game version separated from the GoG/Steam/Beamdog version.

 

You find many useful hints in this discussion:

https://www.reddit.com/r/baldursgate/comments/8unf15/baldurs_gate_ii_enhanced_edition_25_patch/

 

As a main rule: do not patch an ongoing game.

Link to comment

If you have a modded game and you want to continue playing it to the end, you'd better skip the update for now. It will overwrite most of your files and you must start a new game.

Hopefully you followed the instructions to have your modded game version separated from the GoG/Steam/Beamdog version.

 

You find many useful hints in this discussion:

https://www.reddit.com/r/baldursgate/comments/8unf15/baldurs_gate_ii_enhanced_edition_25_patch/

 

As a main rule: do not patch an ongoing game.

And how was I supposed to do that? Steam automatically updates games with no way to stop it.

Link to comment

 

If you have a modded game and you want to continue playing it to the end, you'd better skip the update for now. It will overwrite most of your files and you must start a new game.

Hopefully you followed the instructions to have your modded game version separated from the GoG/Steam/Beamdog version.

 

You find many useful hints in this discussion:

https://www.reddit.com/r/baldursgate/comments/8unf15/baldurs_gate_ii_enhanced_edition_25_patch/

 

As a main rule: do not patch an ongoing game.

 

And how was I supposed to do that? Steam automatically updates games with no way to stop it.

copy game install folder

Link to comment

Have a question, once all platforms are updated will we expect some updates soon for various mods that will need it? My understanding right now that only BG1npc Project and UB were mostly affected due to some fixes made, but however I read as well the UI was apparently changed in some small ways and this could affect certain mods out there. Also I assume K4thos might come back soon since 2.5 is relatively here now? I know K4thos had some plans for EET, and also I think there was some bug reports that only K4thos could solve if I remember correctly as there was something that caused some heavy issue but forgot what exactly it was, I know it was discussed in a topic somewhere.

Edited by Kaliesto
Link to comment

Hi Roxanne!

after like 5-6 uninstalls and reinstalling . i've finally successfully installed EET with the EET mod setup!

but the final try where it succeeds was when i only install the EET and nothing else haha. so what do i do say if i wanna add mods now? let me know? thanks!!

Link to comment

so what do i do say if i wanna add mods now? let me know? thanks!!

Well, so long as you didn't install the EET_end, you'll do fine with nearly any mod, so long as you install the EET_end there after all other mods before you start the game.
Link to comment
Well, so long as you didn't install the EET_end, you'll do fine with nearly any mod, so long as you install the EET_end there after all other mods before you start the game.

 

there is no problem with un-installing and re-installing EET_end even during playthrough. For example if you need to install some other mod or change install order or whatever else you need to do, uninstalling EET_end in order to do so won't cause any issues. Of course adding mods during playthrough is always risky (because usually you need to install them before you visit area that the mod affects) but this has nothing to do with EET_end.

 

but the final try where it succeeds was when i only install the EET and nothing else haha

let me guess, "out of bounds" errors during spell patching like this. It's currently unknown why mods tend to corrupt spells mentioned in the linked topic, but the same is true for vanilla BG2:EE. I would wait before starting large installation until mods that are known to cause it are fixed.

Edited by K4thos
Link to comment

 

Well, so long as you didn't install the EET_end, you'll do fine with nearly any mod, so long as you install the EET_end there after all other mods before you start the game.

 

there is no problem with un-installing and re-installing EET_end even during playthrough. For example if you need to install some other mod or change install order or whatever else you need to do, uninstalling EET_end in order to do so won't cause any issues. Of course adding mods during playthrough is always risky (because usually you need to install them before you visit area that the mod affects) but this has nothing to do with EET_end.

 

but the final try where it succeeds was when i only install the EET and nothing else haha

let me guess, "out of bounds" errors during spell patching like this. It's currently unknown why mods tend to corrupt spells mentioned in the linked topic, but the same is true for vanilla BG2:EE. I would wait before starting large installation until mods that are known to cause it are fixed.

 

you're right haha. got stucked at SCS quite a lot of times, one of the reasons for the first few resets.

 

it's painful man that the moment you see the error message at the EE mod setup you have to unsintall and deliete and redownload everything!

Edited by tedvoon
Link to comment

Hello, I've got a question: is there any chance you could add Bartimaues Item revision to this tool?

Tool ? And who are you asking this from ? Cause there's no such thing as BIR(Bartimaues Item revision). It's Item Revision Revised. And the Item Revisions is in BWS. And most of the fixes are incorporated within the BWS's BWPfixpack.

Link to comment

let me guess, "out of bounds" errors during spell patching like this. It's currently unknown why mods tend to corrupt spells mentioned in the linked topic, but the same is true for vanilla BG2:EE. I would wait before starting large installation until mods that are known to cause it are fixed.

If I recall, the issue is well-understood, it's that the Detectable Spells library doesn't agree with the way those spells are coded in the 2.5 patch.

 

Wisp has already updated DS in Rogue Rebalancing to be compatible with the new patch... we just need someone to apply Wisp's changes to the other mods that include DS (SCS, SR, not sure what else...)

Link to comment

 

Hello, I've got a question: is there any chance you could add Bartimaues Item revision to this tool?

Tool ? And who are you asking this from ? Cause there's no such thing as BIR(Bartimaues Item revision). It's Item Revision Revised. And the Item Revisions is in BWS. And most of the fixes are incorporated within the BWS's BWPfixpack.

 

So the fixes of Item Revision Revised are incorporated into BWPfixpack and it's not needed?

Edited by Sizz
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...